Crystal v ghost crystal royal python. - Reptile Forums

Go Back   Reptile Forums > Help and Chat > Snakes


  #1 (permalink)  
Old 04-09-2020, 02:43 PM
5 Star Member
Join Date: Sep 2009
Location: Manchester
Posts: 3,664
Default Crystal v ghost crystal royal python.

Hi,

Does anybody here have experience with hatching crystal AND ghost crystal royals? Think that I need some help.
Python_Bloke likes this.
Reply With Quote
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-09-2020, 02:50 PM
elishacoombes9's Avatar
Ultra Citizen
Join Date: Sep 2017
Location: South west
Posts: 1,374
Default

If you add images I’m sure we can all help.
I’ve got a Crystal and they’re easy to spot being a bright coloured snake.
Adding ghost seems to make them all one base colour nearly and changes it a lot to a dirty yellow/brownish colour?


Sent from my iPhone using Tapatalk
yardy likes this.
Reply With Quote
  #3 (permalink)  
Old 04-09-2020, 03:08 PM
5 Star Member
Join Date: Sep 2009
Location: Manchester
Posts: 3,664
Default

The issue right now is trying to ID hatchlings. I think that any differences may become more apparent with age, but that isn't my problem at this moment. They are all at least het ghost, so I'm not sure if that will have any bearing either.

image-1267021010305299
12.19MP 4032 x 3024 62.65KB

Ah well that didn't work. RFUK is a nightmare to attach photos to.

Back later - I have to get back to work now. It's proving to be a very long day.

P.S. I have at lest 4 crystals in the clutch, maybe 5.
elishacoombes9 likes this.
Reply With Quote
Sponsored Links
Advertisement
 
  #4 (permalink)  
Old 05-09-2020, 01:40 PM
5 Star Member
Join Date: Sep 2009
Location: Manchester
Posts: 3,664
Default Photos...

https://lh3.googleusercontent.com/fB...-no?authuser=0

Can anyone see this? Otherwise how on earth am I supposed to upload a photo?
Reply With Quote
  #5 (permalink)  
Old 05-09-2020, 01:50 PM
Moderator
Join Date: Jan 2009
Posts: 16,289
Default

Quote:
Originally Posted by yardy View Post
https://lh3.googleusercontent.com/fB...-no?authuser=0

Can anyone see this? Otherwise how on earth am I supposed to upload a photo?
Yes
Reply With Quote
  #6 (permalink)  
Old 05-09-2020, 02:08 PM
elishacoombes9's Avatar
Ultra Citizen
Join Date: Sep 2017
Location: South west
Posts: 1,374
Default

Wait til first shed atleast. Won’t be able to tell unless you’ve had before or someone else has I doubt.
Very cute though!


Sent from my iPhone using Tapatalk
Reply With Quote
  #7 (permalink)  
Old 05-09-2020, 06:29 PM
Premier Member
Join Date: Oct 2009
Location: Stevenage, UK
Posts: 8,026
Default

Nope - I get a black page with a white no entry sign.

There's a sticky above on uploading images - might help
__________________
Regards

Malc



Reply With Quote
Reply

Tags
crystal , royals

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




All times are GMT +1. The time now is 05:33 PM.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright © 2005 - 2011, Reptile Forums (RFUK™)